About | Archive | COD4 Stats | Coordinate Converter (EGSA87, WGS84, HRTS07, HATT)

Sakis' Blog!

Πεταμένος χρόνος (v4)



For the advanced users, this job is done easily with those sets of two lines.

MAC Filtering:

/ip firewall filter
add chain=forward src-mac-address=aa:bb:cc:dd:ee:ff action=drop

IP Filtering:

/ip firewall filter
add chain=forward src-address=aaa.bbb.ccc.ddd action=drop


For the rest, here is how you can do the same, using the Winbox, the Mikrotik GUI.

  • From the Winbox menu, select IP->Firewall
  • On the “Firewall” window, select the “+” sign (add).
  • On the “Firewall Rule” window, select the tab “General” and set the “chain” to “forward”.
  • IF you want to block IP, add it to “Scr. Address” field.
  • IF you want to block MAC, go to “Advanced” tab and add the MAC to the “Scr. MAC Address” field.
  • Then, on the “Action” tab, set the “Action” to “drop”.
  • Finally, click “Apply” to save the new rule.


TIP: try to comment your rules in order to make it easier for you later, when you will review the filters and you will have to search what filter does what. 😉


Source: http://forum.mikrotik.com/viewtopic.php?t=51565

Tags: , , , , , , , , ,

Η προηγούμενη προσπάθεια για multiboot usb stick με την χρήση του grub4dos είχε στεφθεί με απόλυτη επιτυχία με την πολύτιμη προσπάθεια του GeorgeVasil χρησιμοποιώντας το Grub4Dos και παραμετροποιώντας το βασικό μενού και το λογότυπο φέρνοντας το στα μέτρα του OutOfSpecs.gr (RIP). Όλα αυτά στο μακρινό 2010.


Σήμερα, ο κυρίαρχος παίκτης για αυτή τη δουλειά είναι το Easy2Boot , ένα εργαλείο από τον steve6375 (a.k.a. Steve Si

Τα περισσότερα ISO παίζουν απλά με αντιγραφή στον βασικό φάκελο του προγράμματος (\_ISO\MAINMENU), τα windows ISO θέλουν μετονομασία από .ISO σε .isowinvh (π.χ. miniXP) ενώ όσα είναι για εγκατάσταση λειτουργικού, θέλουν αντιγραφή στον σωστό φάκελο πχ I:\_ISO\WINDOWS\WIN7\ . Γενικότερα, η διαδικασία είναι πιο απλή από την προηγούμενη υλοποίηση που έπρεπε συνέχεια να βρίσκουμε δοκιμασμένο κώδικα για το menu.lst.

Στο site υπάρχουν αναλυτικότατες οδηγίες, περισσότερες πληροφορίες σχετικά με το προτζεκτ και την εξέλιξη του στο αντιστοιχο θέμα που υπάρχει στο reboot.pro.

Τσεκάρετε και το blog του Steve εκτός από updates για την εφαρμογή υπάρχουν και άλλα εργαλεία που πιθανόν να μην γνωρίζατε!


Επόμενο βήμα, η δοκιμή του USB stick. Ξεχάστε όσα κάναμε παλιά με τα usb.vmdk του virtualbox . Ο νέος παίκτης ακούει στο όνομα Virtual Machine USB Boot! Αναλυτικές οδηγίες για την εγκατάσταση και την εκτέλεση του θα βρείτε στον σύνδεσμο How to boot directly from a USB drive using an Emulator or VM under Windows .


Γενικά tips από την μέχρι τώρα ενασχόληση μου με το E2B, το VMUB και το Virtualbox.

  • Όταν μεταφέρετε ένα νέο ISO, μην ξεχνάτε να το κάνετε contiguous.
  • Αν το αρχείο σας είναι μεγάλο (πχ 4GB) και το WContig σας λέει ότι δεν βρίσκει ένα τόσο μεγάλο συνεχόμενο κομμάτι στο USB σας, αφαιρέστε κάποια από τα υπάρχοντα ISO, μεταφέρετε το μεγάλο, κάντε το συνεχόμενο, έπειτα επαναφέρετε όσα αφαιρέσατε και τέλος κάντε τα και αυτά συνεχόμενα.
  • Όταν δημιουργείτε ένα αρχείο imgPTN, κάντε το μεγαλύτερο από το μέγεθος του ISO. Ενδέχεται να ξεμείνετε από χώρο καθώς αποσυμπιέζονται αρχεία ή δημιουργούνται νέα αρχεία από τις εφαρμογές.
  • ενεργοποιήστε το PAE (Guest OS->settings->system->processor->Enable PAE/NX) για να γλιτώσετε από προβλήματα με linux kernels
  • ενεργοποιήστε το Host I/O caching (Guest OS->settings->storage->controller Sata->Use Host I/O cache ) για να αποφύγετε προβλήματα (The I/O cache encountered an error while updating data in medium “ahci-0-0”) με μεγάλα ISO, px Gandalf’s Windows 10 PE.
  • Εάν έχετε ένα στικάκι π.χ. 16GB και θέλετε να χωρέσετε 2 μεγάλα ISO ~6gb θα παρατηρήσετε οτι ειναι αδύνατον να γινουν contiguous. Αυτό συμβαίνει γιατί όταν κάνουμε format στο usb, τα $MFT αρχεία εγγράφονται αυτόματα και μόνιμα στην θέση που ξεκινάνε τα 3GB. Για να ξεπεράσουμε αυτόν τον περιορισμό, αφου δημιουργήσουμε το Ε2Β, αλλάζουμε το μέγεθος του E2B partition στο μικρότερο δυνατό (π.χ. με το MiniTool Partition Wizard) ώστε τα αρχεία να μεταφερθούν στην αρχή του partition. Έπειτα το ξαναμεγαλώνουμε στο αρχικό μέγεθος, θα δούμε οτι τα $MFT αρχεία παρέμειναν στην αρχή του partition και πως πλέον μπορούμε να έχουμε contiguous τα 2 μεγάλα ISO μας. Εμπνευσμένο από εδώ.

Ακολουθεί ένα screenshot από το τρέχον setup μου, ακούω προτάσεις για εργαλεία που λείπουν!







When the OS is installed and you try to see what is already installed:

-you can open the file ../Windows/System32/license.rtf with Wordpad. Guess what, it tells you EXACTLY what system is installed. On that same drive above, this file said “WINDOWS 8 PRO”.

When you know the OS version but you don’t know the architecture (x86/x64):

32-bit versions of Windows will only include a single Program Files folder, while the two folders you see above will be present on any 64-bit system. The Program Files (x86) folder is where applications that are meant to run on 32-bit systems are installed. The main Program Files folder is where all 64-bit applications reside.

When you have an installation DVD without knowing the OS, the build version or the language:

Assuming you can mount the image, run cmd as administrator and type:

dism /Get-WimInfo /WimFile:A:\sources\boot.wim

A is your iso mountpoint.


Open 7zip and go to Windows.iso\sources\boot.wim\[1].xml

n there you can find the exact build information similar to this:

<PRODUCTNAME>Microsoft® Windows® Operating System</PRODUCTNAME>


The <version> tag is what tells you the built version. for above example: V 6.1.7601 SP1.17514








I replaced a DVD-RW with this ” SATA to SATA 2nd HDD HD Hard Driver Caddy for 12.7mm Universal CD/DVD-ROM” on a HP ProBook 4530s in order to move there the hdd since i would install an SSD in the main hdd area.


On first shutdown, you can hear everything spinning down (hdd, cpu fan) but the power button led stayed on.

My first thought was to install some missing drivers for the SSD or/and the Chipset. Of course, none of them solved the problem.


After some more thorough googling, I found a guy, who had the same problem with me, but his caddy had a switch inside, while mine didn’t.


Now my search was easier, with one great finding! HP Elitebook 8560p Won’t Shutdown

If you skip the analysis on the link, the fact is that you have to somehow disable the third SATA pin.



I decided to use a more gentle method, I used a small piece of tape to block the third pin contacting the cable connector.


Notice the missing reflection of the third pin ! 😀

Now it shutdowns properly and is booting fast as hell!


Tags: , , , , ,
  1. Open Avidemux (free video editing software)
  2. Open your mp4 file.
  3. Choose Video > Filters (or in Windows, press Ctrl+Alt+F)
  4. Double-click “Rotate” to add that filter
  5. Choose 90 degrees
  6. Press “Close” to exit “Video Filter Manager”
  7. Choose File -> Information to see the attributes of your original video
  8. Choose a “Video Output” other than “Copy” [for LG G2 video choose  “Mpeg4 AVC (x264)”]
  9. Select configure -> General
  10. Encoding Mode -> Constant Bitrate (Single Pass)
  11. Target Bitrate -> 16000 kbit/s and click OK to exit.
  12. Keep audio output on “Copy”.
  13. Select Output Format -> “MP4 Muxer”
  14. Save


source: http://superuser.com/questions/82117/rotate-a-mp4-file-while-preserving-codec-and-quality-attributes